It’s hard to find because the hook name is generated dynamically.
All the get_
functions in the WooCommerce product class, like $product->get_price()
, use the get_prop()
method under the hood. This is part of the WC_Data
class that WC_Product
extends. At the end of get_prop()
the filters are applied like this:
apply_filters( $this->get_hook_prefix() . $key, $value, $this );
And get_hook_prefix()
looks like this:
protected function get_hook_prefix() {
return 'woocommerce_' . $this->object_type . '_get_';
}
So all the get_
methods like get_price()
, get_sku()
, get_description()
etc. will go through a filter with the same format: woocommerce_product_get_{property}
. In your case woocommerce_product_get_price
.
For the new filter, the 2 arguments are the value, $value
, and the product, $this
. So it doesn’t look like you need to change the callback. It should be sufficient to change the hook name.