non-standard syntax; use ‘&’ to create a pointer to member

well…

if (tab_Trj[i]->getNum() == ind)

you forgot the ().

also, in the C++ world, I would advise against writing for (int... , prefer auto or size_t instead of int. comparing signed and unsigned values can lead to errors.

PS. it is extremly not common to name entities in your program in a language which is not english. also, you are mixing underscore-convention with lower camel case-convention.

I’d name the function either rescanTarget or rescan_target, but not rescan_Target (which I believe is the translation for “rechercher_Trajet”?).

Leave a Comment